5ttseg keep original voxel numbers and dimensions


#1

Hi,

After 5ttseg, the dimensions of the 5ttseg.mif output is different from that of the input, even when using -nocrop option. I’m using the WM output for subsequent steps, so it’s slightly problematic to have to do a rigid registration again to the original T1.
Could you please tell me how to keep all the original information in the segmentation output?

Many thanks
A


#2

Hi Adriana,

I have some vague recollection of having fixed an issue with 5ttgen changing the output voxel grid despite having been provided with the -nocrop option. This shouldn’t be happening…

  • Are you using an up-to-date MRtrix3 version?
  • Which 5ttgen algorithm are you using?
  • Are you providing any other command-line options?

Assuming the voxel grid is just being cropped and not reoriented in any way, you should be able to use mrtransform with the -interp nearest and -template command-line options to get back to the original voxel grid with no loss of detail. But obviously my own interest is in solving the underlying issue.

Rob


#3

Hi Rob,

Thanks for getting back to me.
Yes I am using MRtrix3 and the fsl algorithm.
I am currently using mrtransform following 5ttgen. But since I’m applying this to many images and have to QC after each step, I thought I might be missing something with the 5ttgen command to prevent it from changing the voxel grid.

Thanks again,
Adriana


#4

Yes I am using MRtrix3 …

Can you provide a more precise version (i.e. output of mrconvert -version)?


#5

The following version, from June 22 2018
== mrconvert 3.0_RC3-51-g52a2540d ==