Dwi2mask output does not include the CC

preprocessing

#1

Dear all,
I like to create a whole brain mask for dwibiascorrect, dwi2tensor, and dwi2fod
When I use dwi2mask, it excludes the posterior Corpus Callosum.


dwi2tensor%20(mask)

I played with maskfilter. (dilate, median))
For – dilate -npass 5, It include the Corpus Callosum but it also include a lot of non-brain (attach- mask and tensor)

T1W

I will much appreciate your help!
Tali


#2

Hi @tali,

This is probably because your diffusion images have a large bias field. Any chance you could provide a snapshot of your b=0 images as well, just to confirm?

If that’s the problem, you might find that running your DWI images through dwibiascorrect -ants will probably sort out the problem…

Cheers,
Donald.


#3

Thanks for your quick reply!

b0:

I use the fsl option without the mask option
dwibiascorrect -fsl geomcorr.mif biascorr.mif -bias biasfield.mif
and then:
dwi2mask geomcorr.mif geomcorr_mask.mif
overlay of geomcorr_mask.mif on T1W

The posterior CC is still excluded from the mask :frowning:


#4

Yes, clearly a very strong bias field is present. Not surprising then that you’d have that gap in your masks; as @jdtournier mentioned, you’ll need to do something about that bias field first.

Don’t use the -fsl option; it introduces more problems than it fixes, especially with better masking in mind. Use the -ants option instead.

Apart from the “don’t use -fsl option” advise, nonetheless: shouldn’t this have been biascorr.mif instead of geomcorr.mif? I.e., the output of dwibiascorrect? But in any case, try to use the -ants option instead for sure.


#5

THANK YOU!!!

  1. Indeed, it works with ants!
    an example of the biasfield.mif of one subject.
    what is the best check to verify that dwibiascorrect did a good job?


#6

:pray:

:tada: That result also looks quite like what I would expect from ANTS.

Well, the output you show in that screenshot looks “decent”. It’s hard to truly verify, since we don’t have the ground truth bias field to compare with of course. However, in your original dataset, the problem was (visibly) that the centre of the brain had much lower intensities than the edges. Just look at e.g. the b=0 signal in the ventricles compared to fluid on the outside of the brain to see that. The bias field output (which you showed in hot colour scale in the screenshot) should reflect that, since that’s what it’s trying to estimate… and indeed it does show that pattern: darker in the middle of the brain, brighter on the outside. Beyond the brain area, you can ignore that bias field output (or rather: don’t go by what it does all the way beyond the brain to check its quality), just check it inside of the brain area.

Cheers,
Thijs