How to draw "free" shape ROI in coronal direction

mrview

#1

Dear all,
I want to know how to draw arbitrary shape ROI in coronal direction like in sagittal and axial direction using ROI editor Tool.
When I edited ROI using a brush in sagittal and axial direction, it can be drawn any shaped ROI. However, when I drew in coronal direction, it only appeared many straight lines.
I will be appreciated for your help.

Best
Zhaoqing Li


#2

Hi Zhaoqing,

There shouldn’t be any restrictions on the plane used for drawing ROIs, other than the fact that it needs to be aligned with the axes of the ROI image itself (this is only a problem if you’re drawing on a ROI image that has different dimensions, voxel sizes and/or orientation from the main image).

Do you mean that once you’ve drawn your ROI in the axial or sagittal plane, it appears as separate planes when viewed in the coronal plane? Or is it literally not possible to draw on the coronal plane as expected? Can you maybe post a screenshot to illustrate?

Cheers,
Donald.


#3

Hi Donald,
Thanks for your reply.
The problem is when I move the “pencil” freely in the coronal plane, it can not draw any shape. It just appears many straight lines like the attachment “coronal” shows.


But when I draw in the sagittal or axial plane, it can be drawn some shape like the attachment “sagittal” shows.
What I want to draw is a 3D ROI. Because I only have the 2D standard atlas in coronal direction.

Best
Zhaoqing


#4

OK, that is unexpected, and worrying… Unfortunately, I can’t reproduce the issue on my system – it all works as expected.

Can you post more details about your system? I’d like to know the exact version of MRView used (click Help → about MRView), the OS and version, the graphics card and driver used (click Help → OpenGL information), and some details about the image (the output of mrinfo your_image.mif should do it).


#5

Oh, one more question: does this happen when drawing in single-slice mode too, or just in orthoview mode?


#6

MRView version : The MRtrix viewer, version 3.0_RC3-18-g6d496caf
64 bit release version, built Jun 1 2018

OS : I install MRtrix3 on the VMware ubuntu 16.04 ,64bit,
the version of VMware is WORKSTATION Pro 14.
OS of my host computer in window 7.

graphics card and driver : OpenGL

information of image :

By the way, this problem happened both in drawing in single-slice mode and in orthoview mode.


#7

OK, you’re running within a WM, using the open-source mesa drivers, which provide software rendering (as far as I know). It’s a recent version though, so it ought to work relatively well. But until recently, I didn’t think it was possible to do what you’re doing at all… There’s a chance this might be down to an issue with the OpenGL drivers on your VM – although it still sounds like a strange issue to be having… Is there any chance you could try installing MRtrix in Windows directly, see if the issue persists?

There’s nothing particularly exotic with your data either, and it’s isotropic, so difficult to see why coronal would be affected in particular. I’ll try creating an image with those parameters and see if that triggers anything on my system…


#8

OK, I just tried with an image with the same parameters as yours, and I can draw on that as expected. I think it might be an issue with the OpenGL drivers on your particular setup. You could try updating the mesa drivers on the guest OS, upgrading the graphics card drivers on the host OS, and/or updating VMWare itself (or maybe even downgrading if it’s the latest). Other than that, it’s going to be difficult to see how to fix this…


#9

Thanks very much for your advice. I will try it. :slight_smile: