How to use 5ttedit -path

tractography

#1

Dear experts,

I tried to use ACT to do global tractography in patients with lesion.
After the

5ttgen fsl -nocrop t1_brain.nii 5TT_brian.mif

And I found there are some fibers in the rumor where I think seems shouldn’t.
Even there are some fibers in the tumor, I think they should be a little outside.


Then I expect ‘5ttedit -path’ would help me. Then I mask the lesion. And run

5ttedit -path lesion.nii.gz 5TT_brain.mif 5TT_brain_edit.mif

And the value of lesion area is all ‘0’.

After the global tractography the fibers in the lesion area are even more.

Did I do any wrong step?? Or ‘5ttedit -path’ is not for this function.

Best regards,
Ziqian


#2

OK, two things:

  • the 5TT image is a 5 volume image, corresponding to GM, DGM, WM, CSF, and pathology (see docs). You’re only showing the first volume, basically saying that there is no GM at that location, but this doesn’t say anything about what tissue type is at that location (WM, DGM, pathology…).

  • if you’ve set this region to pathology using the 5ttedit -path command, then bear in mind that what this does is to instruct tckgen -act to disable all ACT priors – it simply tracks as best it can, the streamline won’t be discarded due to early termination, etc. It does not prevent streamlines from propagating in that region. If that’s what you’re after, it would be simpler to mask out the region altogether from all volumes in the 5TT image (I guess – @rsmith may have better suggestions).