Using HCP data to create connectome of AAL atlas, while the endpoints of tracks distribute in other regions

connectomics
tractography
mrview
#1

Hello all,

I used the HCP data set and get connectomes of AAL atlas, the scripts are as followed:

5ttgen fsl …/raw_data/T1w_acpc_dc_restore_brain.nii.gz 5TT.mif -premasked
flirt -in /Users/bclab/Desktop/mask/aal.nii -ref …/raw_data/T1w_acpc_dc_restore_brain.nii.gz -out aal2T1
mrconvert …/raw_data/data.nii.gz DWI.mif -fslgrad …/raw_data/bvecs …/raw_data/bvals -datatype float32 -strides 0,0,0,1
dwi2response msmt_5tt DWI.mif 5TT.mif RF_WM.txt RF_GM.txt RF_CSF.txt -voxels RF_voxels.mif
dwi2fod msmt_csd DWI.mif RF_WM.txt WM_FODs.mif RF_GM.txt GM.mif RF_CSF.txt CSF.mif -mask …/raw_data/nodif_brain_mask.nii.gz
tckgen WM_FODs.mif 120wan.tck -act 5TT.mif -backtrack -crop_at_gmwmi -seed_dynamic WM_FODs.mif -maxlength 300 -select 1200000 -cutoff 0.06
tck2connectome 120wan.tck aal2T1.nii.gz connectome.csv -out_assigned sift_path
mkdir -p tck_roi
connectome2tck -nodes 1,2,3,4,5,6,7,8,9,10 -exclusive 120wan.tck path tck_roi/tck
mrview DWI.mif -tractography.load sift_tck_roi/tck1-2.tck

Based on the “-out_assignments” of tck2connectome, I created the tracks files belong to pairs of ALL regions. As I checked the track between Precentral_L and Precentral_R, there were still some tracks distributed in other areas of brain, as you can see in below picture:

Is this a normal result or is there any error in my scripts?
Besides, I wonder if the mrview could show the tracks in a 3D way like dsistudio?

Liuyuchen

#2

Hi,

  1. You may would like to use tckresample connectome2tck.tck connectome2tck_endpoints.tck -endpoints to see the if the fibers end at same point.

show the tracks in a 3D way

You could press F3 to see the volume render results and then change the ‘alpa’ in the ‘View Option’ to 0. Hope this is what you are looking for.

Best,
ziqian

#3

Hi,

  1. I don’t quite understand the output figure, does this mean that fibers don’t end at same point?

  2. Yes this solved my problem, thanks for your reply!

Liuyuchen

#4

Plus, could mrview show all 3D images of 3 direction together?

#5

Hi,
you could use the Volume Render option and show the tractogram. Then press ‘M’ to hide the main image to only display the tractogram. It will maybe give you a clue.

Ziqian

#6

What do you mean ‘all 3D images’?

#7

Hi Ziqian,

Thank you again, it helps a lot

#8

Hi, Ziqian,

I wonder if tracts chould shown like this:

#9

Hi yuchen,

in Volume Render view, you could use Tool–>View Option to display a similar result by thresholding the parameters.

Best,
Ziqian