When runing the MSMT CSD program, the display of ODF is little. what means can I increase it?


#1

I run the MSMT CSD and mrview the odf, but it so little to see, what kinds of means can I amplificate it?
and how can I save the piture with the big image resolution?


#2

Hi @maytian,

Thanks for your interest in and usage of MSMT-CSD. The reason why the FODs from MSMT-CSD are typically a bit smaller compared to the ones from (single-shell single-tissue) CSD, is due to 2 reasons:

  • The signal from GM and CSF (and possible other contributions) is taken out; so the FODs in e.g. the cortex will appear rather tiny (but useful, rather than full of random peaks, as compared to the regular CSD)

  • The MSMT-CSD is implemented using a hard non-negativity constraint, whereas the old CSD uses a sort of iterative regularisation to achieve a similar effect. However, the latter is not as “hard”, so still allows for some negative peaks. This in turn allows the positive lobes to be somewhat sharper, so in terms of sheer “peak” (i.e. maximum) amplitude, they look larger in the visualisation.

All of this to say that there’s nothing wrong with your FODs appearing a bit smaller (but the effect shouldn’t be too drastic though).

To make things larger in the visualisation, there’s a field called “scale” in the ODF display tool. By default it has a value of “1” (this just refers to the default; the number itself has no meaning otherwise). If you increase this, you’ll see your FODs become larger in the visualisation. To make this a bit more interactive, you can actually click inside that field, hold the mouse button, and drag upwards to increase the number in a continuous manner (but entering a number larger than 1 will work just as well).

Cheers,
Thijs


#3

Hi @maytian ,
You also might get FODs that are smaller than expected when the response functions are computed on one DWI image, then you compute the FODs from another. For example, if you were to compute the response functions first, then compute FODs on the DWI output from dwiintensitynorm (which scales the intensity of the image).
Cheers,
Dave


#4

how can I save the piture with the big image resolution?

The screenshot tool in mrview will only capture images at the resolution at which they are displayed. You can however try setting the MSAA field in your MRtrix3 configuration file, which will use anti-aliasing to improve the smoothness of your images (essentially generating them at a higher resolution internally, then down-sampling them before writing to the display). So they should at least appear less pixelated, and therefore ‘higher quality’, though not strictly ‘larger resolution’.