Build step error

hello all
hello all
I tried to install the mrtrix and after the configuration step
I met this error here.
ERROR: ( 93/234) [CC] tmp/src/gui/gui_moc.o

g++ -c -std=c++11 -DMRTRIX_BUILD_TYPE=“release version” -pthread -fPIC -DMRTRIX_WORD64 -DMRTRIX_TIFF_SUPPORT -isystem /usr/include/x86_64-linux-gnu -DEIGEN_FFTW_DEFAULT -Wall -O3 -DNDEBUG -Isrc -I./core -Icmd -isystem /usr/include/eigen3 -DEIGEN_DONT_PARALLELIZE -m64 -pipe -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_SVG_LIB -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -isystem /usr/share/qt4/mkspecs/linux-g+±64 -isystem /usr/include/qt4/QtCore -isystem /usr/include/qt4/QtGui -isystem /usr/include/qt4/QtOpenGL -isystem /usr/include/qt4/QtSvg -isystem /usr/include/qt4 -isystem /usr/X11R6/include tmp/src/gui/gui_moc.cpp -o tmp/src/gui/gui_moc.o

failed with output

virtual memory exhausted: Ne peut allouer de la mmoire

ERROR: ( 88/234) [CC] tmp/cmd/mrregister.o

g++ -c -std=c++11 -DMRTRIX_BUILD_TYPE=“release version” -pthread -fPIC -DMRTRIX_WORD64 -DMRTRIX_TIFF_SUPPORT -isystem /usr/include/x86_64-linux-gnu -DEIGEN_FFTW_DEFAULT -Wall -O3 -DNDEBUG -Isrc -I./core -Icmd -isystem /usr/include/eigen3 -DEIGEN_DONT_PARALLELIZE cmd/mrregister.cpp -o tmp/cmd/mrregister.o

failed with output

g++: internal compiler error: Processus arrt (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-7/README.Bugs> for instructions.
/tmp/tmpUchAlZ (END)

You’re running out of RAM / swap space. Try to compile MRtrix with


and if that does not work, close other applications that require a lot of RAM and/or allocate more swap space. What is the output of free -m?

thank you max for your reply
but the problem is that I dedicate 5 GO of RAM but the problem remains the same !!
what do u mean by What is the output of free -m ?

5GB of RAM should be enough. On my system, the maximum memory required to build MRtrix (current master, MRtrix build type requested: release version, clang 3.8.0-2ubuntu4) is 1662MB.

When you execute free -m you should see a summary of total, free, and available memory and swap space. The available space should be above 1662 or at least the sum of available Mem and free Swap should be above that.

Did you execute the command NUMBER_OF_PROCESSORS=1 ./build?

Setting NUMBER_OF_PROCESSORS to 1 should make the build script create one object file at a time (instead of processing multiple in parallel) to reduce the required memory. If this does not work, you could try using a different compiler: clang might require less memory than g++.

hello again max , thanks very well it’s done building step
but when i run mrview, it’s nothing posted