Dwidenoise error - fail to set a file suffix

Hi MRtrix3 Community,

I ran into this error using dwidenoise this morning. My command is basically as below:

dwidenoise DWI.mif DWI-denoise.mif 

However, the response message shows that “It could not create I0 object for reading file DWI.mif” … You probably failed to set a file suffic, or set the suffix to an unsupported type.

I have checked all the image library, do the configuration and also tried to re-install MRtrix3. But it did not help. I was still able to perform denoising two days ago. Could anyone happen to know this issue and how to fix it?
Thank you so much,


Hi Van,

It’s really hard for us to figure out what happened without a much more precise description of the issue. Could you run your command with the -debug flag, e.g.:

dwidenoise DWI.mif DWI-denoise.mif -debug

and copy/paste the entirety of the output, including the command itself, into your reply? Please avoid taking screenshots, it’s much more useful for us to have the exact text as typed so we can copy/paste it and try it out on our side. Also there are sometimes issues with characters that look like regular ASCII characters, but are actually different similar-looking Unicode characters, which are difficult to spot from a screenshot.

Also provide details of your operating system, which version of MRtrix you’re using (e.g. dwidenoise -version), and double-check that there is enough space to store the output file and that you have the appropriate permissions to write there.

Hi J-Donald,
Sorry for my late response. Here is the description of the issue. Could you please help me to look at this?

libc++abi.dylib: terminating with uncaught exception of type itk::ImageFileReaderException: /Users/irfanogo_local/Desktop/UK_trip_data_software_code/code/libraries/InsightToolkit-4.13.0/Modules/IO/ImageBase/include/itkImageFileReader.hxx:143:
Could not create IO object for reading file DWI.mif
Tried to create one of the following:
You probably failed to set a file suffix, or
set the suffix to an unsupported type.

Thank you so much in advance,

OK, that’s not one of ours… The error message you’re getting originates from ITK, and it’s telling you that ITK doesn’t support MRtrix’s .mif format (which is fair enough). ITK is a library used by many imaging applications, but not MRtrix. I’m not sure what command you ran to generate this error message, but it can’t be dwidenoise – at least not our dwidenoise

Is anyone else aware of another application built on ITK that happens to also be called dwidenoise…?

no, there can not be an other dwidenoise !!! (if yes it can not be as good ! :wink:)

to check just try

which dwidenoise

it should point to the install path of mrtrix. I would rather suspect a bad library link, to better understand, you could try

ldd dwidenoise

not sure but the equivalent for mac seems to be,

otool -L dwedenoise

1 Like