Generating FA Population Template

Mrtrix Experts,

Could someone please comment on how long it takes to generate an FA population template. I have 148 subjects with a folder containing the mifs and a separate folder containing the masks. I ran the dwiintensitynorm command and it has been hung up for about 20 hours but hasn’t generated any errors. I checked my activity monitor and it doesn’t appear that anything is running so I am assuming there is an issue.

Command that I ran:

dwiintensitynorm DWI_mifs/ DWI_masks/ DWI_intensity_nomrmalised_output/ output_FA_template.mif output_template_wm_mask.mif -force

Terminal looks like this for ~20 hours: - (I also included a screen shot of my terminal window)

Command: dwi2tensor

dwiintensitynorm: Generating FA population template
Command: population_template fa -mask_dir /tmp/dwiintensitynorm-tmp-I81L2G/DWI_masks fa_template.mif -linear_scale 0.25,0.5,1.0,1.0 -nl_scale 0.5,0.75,1.0,1.0,1.0 -nl_niter 5,5,5,5,5 -warp_dir warps -nocleanup -tempdir population_template

Hello jbishop,

20 hours seems too long for population_template. What is the last file that was modified in your tempdir? (untested:
find /tmp/dwiintensitynorm-tmp-I81L2G -type f -exec stat -lt "%Y-%m-%d" {} \+ | cut -d' ' -f6- | sort -n | tail -1)

Also, what are the last entries in the command log in /tmp/dwiintensitynorm-tmp-I81L2G/population_template?

Hello Max,

After running the command:
find /tmp/dwiintensitynorm-tmp-I81L2G -type f -exec stat -lt “%Y-%m-%d” {} + | cut -d’ ’ -f6- | sort -n | tail -1

I get the following output:
2016-10-13 /tmp/dwiintensitynorm-tmp-I81L2G/population_template/masks_transformed/3417.mif

In the /tmp/dwiintensitynorm-tmp-I81L2G/population_template directory it also appears to have generated other files but its still hung up.


I’m not sure if I processed something wrong. I have attached a screenshot of my preprocessing script as well.

Thanks in advance for your help.


Hello James,

population_template did hang before but never in a reproducible way. A workaround™ is to abort the running dwiintensitynorm script, delete (or move) /tmp/dwiintensitynorm-tmp-I81L2G/population_template and rerun the dwiintensitynorm call with the -continue option. You can find the command, the script was called with, in /tmp/dwiintensitynorm-tmp-I81L2G/command.txt. After that, you would need to manually execute the last steps of your script, though.

I would like to find out where popultion_template hangs. Could you please send me the output of
ls -Rlhrt /tmp/dwiintensitynorm-tmp-I81L2G/population_template/ before you delete it?

If it hangs again, could you also please rerun population_template manually with the -verbose option and post the output or send it to me?