Missing nodes and unassigned streamlines

Dear experts,

I am using an custom made atlas and have numbered the ROIs 1-90. I have registered to b0 image and it looks okay.

However when I run tck2connectome I get the following errors (I am not sure why it thinks there are more than 90 ROIs);

tck2connectome: [WARNING] The following nodes are missing from the parcellation image:
tck2connectome: [WARNING] 93, 94
tck2connectome: [WARNING] (This may indicate poor parcellation image preparation, use of incorrect config file in labelconfig, or very poor registration)
tck2connectome: [100%] Constructing connectome
tck2connectome: [WARNING] The following nodes do not have any streamlines assigned:
tck2connectome: [WARNING] 12, 51
tck2connectome: [WARNING] (This may indicate a poor registration)

Thanks for your help.

bw

Peter

Hi Peter,

Have you run mrstats on your parcellation image? The command would not report that nodes 93 and 94 are missing unless there is at least one voxel in your image with a value of 95 or greater. Beyond that, with such limited information I can’t really offer any information over and above the warnings issued by the command, other than that you need to check your data carefully.

Rob

Hi Rob,

When I run mrstats I get the following output;

     volume         mean       median    std. dev.          min          max       count
     [ 0 ]       3.90637            0      15.1056            0           85       506880

Thanks

Peter

OK, that’s very strange; mrstats reports a maximum node index of 85, but tck2connectome clearly thinks there’s more than that. It’s a fairly basic piece of code, so it’s hard to envisage how this could be going wrong. Would it be possible for you to provide me with some example data so that I can try to reproduce the fault?