Mrview error with library xcb

Hello :
I am having some issues when running mrview. The problem has met when I tried to install the MRtrix3tissue and reboot the machine. The mrview returned with the error message like this :

Cannot load library /home/opt/Qt5.14.0/5.14.0/gcc_64/plugins/platforms/libqxcb.so: (/lib64/libQt5XcbQpa.so.5: symbol _ZN11QFontEngine14bitmapForGlyphEj6QFixedRK10QTransform, version Qt_5_PRIVATE_API not defined in file libQt5Gui.so.5 with link time reference)
QLibraryPrivate::loadPlugin failed on "/home/opt/Qt5.14.0/5.14.0/gcc_64/plugins/platforms/libqxcb.so" : "Cannot load library /home/opt/Qt5.14.0/5.14.0/gcc_64/plugins/platforms/libqxcb.so: (/lib64/libQt5XcbQpa.so.5: symbol _ZN11QFontEngine14bitmapForGlyphEj6QFixedRK10QTransform, version Qt_5_PRIVATE_API not defined in file libQt5Gui.so.5 with link time reference)"
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, webgl, xcb.

when I tried to run mrview -debug, it gave me the same error messages.

Can anyone provided some advice of this error?

Hi,

It sounds like you’ve had to compile MRtrix3tissue from source, and as part of that, you’ve maybe decided to install a separate version of Qt5? The problem is that the version of Qt5 you’ve installed (in /home/opt/Qt5.14.0/5.14.0) conflicts with your existing system version (in /lib64/). There’s a number of things you can do to get around this.

The simplest (and my recommendation) is to keep using the regular version of MRtrix3 for everything but the actual SS3T step (it’s also the version we actually support). You can do this by removing MRtrix3Tissue from your PATH (you’ll likely need to edit your ~/.bashrc to do this), and invoke SS3T by specifying its complete location (i.e. ~/MRtrix3tissue/bin/ss3t_csd_beta if that’s where you installed it – I can’t tell from your post).

The other thing you can do is remove the conflicting Qt version, install the official Qt5 development packages for your system (the procedure depends on your OS), then recompile SS3T. This shouldn’t be required if you’re happy to keep using the official MRtrix3 version of mrview though…

All the best,
Donald

Hi:
Thank you so much for your advice ! It works when I re-edit the LD_LIBRARY_PATH and remove the SS3T path from .bashrc.