[SOLVED] Global tractography crash

Hi everyone. I tried to run tckglobal on one of the human connectome datasets (subject 994273, preprocessed data). Unfortunately it results in a Segmentation fault (core dumped) after a couple of second, probably right after loading the dataset.
Here is my processing pipeline:

  1. Generate tissue segmentations:
    5ttgen fsl T1w_acpc_dc_restore_brain.nii.gz 5TT.mif -premasked

  2. Convert DWI data to mif format:
    mrconvert data.nii.gz dwi.mif -fslgrad data_rounded.bvecs data_rounded.bvals -datatype float32 -stride 0,0,0,1

  3. Estimate response functions:
    dwi2response msmt_5tt dwi.mif 5TT.mif wmr.txt gmr.txt csfr.txt

  4. Start global tractography:
    tckglobal dwi.mif wmr.txt -riso csfr.txt -riso gmr.txt -mask mask.mif -niter 1e8 -fod fod.mif -fiso fiso.mif tracks.tck

-> crash

The mrtrix installation is fresh (today). Same for fsl.
Any suggestions? I could also provide the data if that helps.


Hi Peter,

This issue likely relates to the multithreading, which has been causing issues on non-macOS platforms. Apologies, I should really document this better until I implement a proper fix… Which OS are you using?

My latest try at a fix is in github branch tckglobal_fixes, but unfortunately it has not yet resolved the issue on all platforms. Alternatively, you can run the command single-threaded, which will be slower but should run without problems. To do that, just run:
tckglobal ... -nthreads 1

Hope that helps,


I think this is the first time that I encounter a feature in a research toolkit that ONLY works on os-x. Usually it’s the other way round :smiley:
Single threaded processing seems to work, thank you!

Hi Peter,

This issue should be now fixed by pull request #824, which has been merged to master. Let me know if you experience any more issues.