Tck2connectome missing nodes

Hi developers,

I would appreciate if you help me to fix the following problem:

I am running this syntax using LUT file from FreeSurfer/v6.0 and Parcellation output from FastSurfer (the updated version of FreeSurfer):

tck2connectome -zero_diagonal -tck_weights_in …/Sub001_sift2_weights.csv …/Sub001_wb_1st_45_fod07_act_20M.tck Sub001_nodes_GMfix_v6_map.mif Sub001_Connectome_v6_map.csv -out_assignment Sub001_assignments_v6_map.csv

The warnings are:
[WARNING] The following nodes are missing from the parcellation image:
tck2connectome: [WARNING] 1, 31, 32, 50, 80, 81
tck2connectome: [WARNING] (This may indicate poor parcellation image preparation, use of incorrect or incomplete LUT file(s) in labelconvert, or very poor registration)
tck2connectome: [WARNING] Streamline weights file contains less entries than .tck file; only read 0 streamlines
tck2connectome: [WARNING] The following nodes do not have any streamlines assigned:
tck2connectome: [WARNING] 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 33, 34, 35, 36, 37, 38, 39, 40, 41, 42, 43, 44, 45, 46, 47, 48, 49, 51, 52, 53, 54, 55, 56, 57, 58, 59, 60, 61, 62, 63, 64, 65, 66, 67, 68, 69, 70, 71, 72, 73, 74, 75, 76, 77, 78, 79, 82, 83, 84
tck2connectome: [WARNING] (This may indicate a poor registration)[WARNING] The following

Hi Suzi,

Given there’s more going wrong here than right, attempting to explain every possible combination of issues would take more effort than rewriting the relevant documentation. I can really only recommend going well back in your pipeline—probably to the first point at which you read data from FastSurfer—and manually checking all of the data at every step. The BATMAN tutorial might help to show what the data at each step are expected to look like.

Cheers
Rob

Thanks a lot Rob for your help.
Well I think the issue is the “FastSurfer” does not have its own LUT table and during “labelconvert” or “labelgmfix” I tried both “FreeSurferColorLUT.txt” from FreeSurfer versions 6.0 and 7.1 but both gave the same error mentioned previously.
Anyway, I again did the parcellations using FreeSurfer/6.0 and it is working perfect.

Cheers,
Suzan

Hi Suzan,

If FastSurfer is generating data using indices that are different to that of FreeSurfer, that doesn’t preclude its use here. It simply requires generation of the requisite lookup table files corresponding to the parcels as produced by the software, and the parcels as you wish them to be included / ordered in the generated connectome, as per the operation of the labelconvert command. Anyone willing to generate such files would likely not only get thanks from other users in a similar situation, but also get the opportunity to contribute to an open source software package…

Cheers
Rob