Tck2connectome nodes have no streamlines assigned

Dear all,
When I am trying to use ’ tck2connectome ’ to generate the connectome with the .tck file on the AAL116 template, some nodes do not have any streamlines assigned. This only happens when I use the DTI method to do the fibertracking. When I use the CSD method, although still don’t know if I do it correctly or not, at least all nodes have streamlines assigned.

I used the command bellow:
(DTI method):
tckgen eddy_denoise.mif track.tck -algorithm fact -cutoff 0.1 -angle 45 -mask dti_mask.mif -select 200k -seed_image dti_mask.mif -force
tck2connectome -zero_diagonal dti_mask.mif track.tck aal_diff.nii.gz connectome_FN.csv

The ’ eddy_denoised.mif ’ is the diffusion image after dwidenoise(use mrtrix3) and eddy_correct(use FSL), ’ dti_mask.mif ’ is the mask generated by the ’ eddy_denoised.mif '. The ’ aal_diff.nii.gz ’ is the AAL116 template which is registered to the b0 image(I use ’ bet ’ command offered by FSL to remove the skull bones) eddy_denoise.mif, and I think the registration is not that bad:

Here is the warning:
tck2connectome: [WARNING] The following nodes do not have any streamlines assigned:
tck2connectome: [WARNING] 30, 31, 32, 33, 34, 35, 36, 37, 38, 41, 42, 71, 72, 73, 74, 75, 76, 77, 78, 95, 96, 98, 709, 111, 114, 115, 116
[WARNING] (This may indicate a poor registration)
Any help would be appreciated.

I tried to use the aal116 template which is registered to the betted b0 image as the ’ -mask ’ and ’ seed_image ’ directly instead of using the mask generated by the preprocessed dti image, it didn’t give me the warning. Is this operation okay? Dose it mean that my registration is bad?

I tried to change the subject and do the same operation as I did in the first post, the warning came out again and I found the number of nodes’ which do not have streamlines assigned are almost the same.

My tracking result looks like this:

It looks different from the normal result.