Tractography Error

Dear Mrtrixers,

Hi! I’ve encountered another problem while using our data.
We’ve done a probabilistic tractography and got an incomplete one compared to the tractography that we’ve done in the tutorial.
Here’s a comparison between the two. (left: tutorial tractography, right: our wrong one)

What could have gone wrong!
Please help us with figuring this out.
We appreciate your help so much.
Thanks you so much!

Sujin Park.

Hi Sujin,
This may happen when the x-component of your gradients is inverted (see this thread). Depending on your data, you could use dwigradcheck to try to revert it. This solution worked in my data but I let the rest of the community to check whether this is a correct way to check the x, y and z bvecs:

mkdir dwicheckgrad
mrconvert PA_dwi.nii dwicheckgrad/PA.mif -fslgrad PA_dwi.bvec PA_dwi.bval
mrconvert AP_dwi.nii dwicheckgrad/AP.mif -fslgrad AP_dwi.bvec AP_dwi.bval

cd dwicheckgrad/

mrconvert PA.mif PA.nii.gz -export_grad_fsl PA.bvecs PA.bvals
dwigradcheck PA.nii.gz -fslgrad PA.bvec PA.bval -export_grad_fsl PA2.bvec PA2.bval
mrconvert AP.mif AP.nii.gz -export_grad_fsl AP.bvecs AP.bvals
dwigradcheck AP.nii.gz -fslgrad AP.bvec AP.bval -export_grad_fsl AP2.bvec AP2.bval

mrconvert ../PA_dwi.nii PA2.mif -fslgrad PA2.bvec PA2.bval
mrconvert ../AP_dwi.nii AP2.mif -fslgrad AP2.bvec AP2.bval

Thanks for your reply :slight_smile:
I tried dwigradcheck as u have shown and there was a slight improvement, but guess that wasn’t a cause.
Anyway, I really appreciate ur help. :joy: