Unable to Use MRview

Hello all, I’ve been trying to open up mrview on Almalinux 9.2 for a few weeks now with no success. I first tried it on a virtual machine through almalinux and ubuntu, then I tried dual booting on Almalinux and ran into the same error. I’ve tried various workarounds but none of them have worked for me. I’m fairly new to linux and so I feel like I must have made a very basic error. I’ll put my steps and error message below:

  1. Install almalinux 9.2 on a partitioned disk.
  2. Install and update anaconda
  3. Install and update MRtrix3
  4. Attempt to run MRview, receive the following error:

Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, minimal, minimalegl, offscreen, vnc, webgl, xcb.

Is there anything simple that I’m missing or any workaround I may not have tried? Thank you all for your help.

I also had similar issue. Try to compile the source code of mrtrix

Hi @Ivan_Campbell,

I suspect an issue with the version of Qt that ships with anaconda, maybe due to a recent upgrade on their side. Any chance you can try running this line:


Before invoking mrview again (in the same terminal)?

It should produce a lot of detail about things, please copy/paste the full output back here for us to inspect.