Upgrade issues

I’m not a software developer so apologies if this is a naive question!I have just tried to upgrade myversion of MRTRIX3, but seem to get stuck during the build part. I get this error message. Any tips on what is going on? I"m running this on ubuntu.

ERROR: ( 54/443) [CC] release/cmd/mrregister.o

ERROR: ( 54/443) [CC] release/cmd/mrregister.o

g++ -c -std=c++11 -mno-avx -pthread -fPIC -march=native -DMRTRIX_WORD64 -isystem /usr/include/eigen3 -Wall -O2 -DNDEBUG -Isrc -Icmd -I./lib -Icmd -isystem /usr/include/eigen3 cmd/mrregister.cpp -o release/cmd/mrregister.o

failed with output

g++: internal compiler error: Killed (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-4.8/README.Bugs> for instructions.

You are likely running out of RAM. Try:


Just wanted to point out that it doesn’t look like you’re running the latest version… Either that or you didn’t run ./configure again before invoking ./build. Those -noavx and -march=native options to the compiler are no longer current, and output files should no longer end up in the release folder…

But I doubt that’s the reason for the crashes you’re seeing, as @maxpietsch says, this is typically what happens when the compiler runs out of RAM - and for some reason, mrregister is particularly demanding to build…

Thanks guys. RAM issues are not new to me! i did repeat the ,/configure command before ./build.

Hi Rishma,

Definitely check these update instructions: http://www.mrtrix.org/2017/04/23/mrtrix3-version-3-0-release-candidate-1/

As @jdtournier mentioned, things have (drastically) changed since this update!


Are you sure? Did you do a git pull to update the code before running ./configure again? If that’s the case, something odd is going on… What does git describe report?

git describe gives me this:


Ok, the latest version should start with 3.0_RC1. this isn’t a problem if you’re not expecting this to be the latest version, but if you were expecting to be up to date, then something didn’t work. This really should work ok if you do:

git checkout master
git pull

Then check whether git describe reports the expected version…

Thanks donald, i tried those commands and git describe still gives me the same version. i think i may just do a clean uninstall of the existing version and install the new version instead of trying to upgrade.

1 Like

That’s probably the safest approach. I’ve been doing exactly the same with several peoples’ installs over here to bring them up to date without hassle and to avoid any future worries. :thumbsup: