"dcminfo -tag" broken?


#1

Is this correct behaviour of dcminfo -tag ?

dcminfo IM-0007-0208.dcm -all | grep WaterFatShift
[DCM] 2001 1022 FL        4     5644   WaterFatShift                          [ 1.00077 ]
dcminfo IM-0007-0208.dcm -tag 2001 1022
A??

but

dcminfo IM-0007-0208.dcm -all | grep Leuven
[DCM] 0008 0080 LO        8      778   InstitutionName                        [ UZLeuven ]
dcminfo IM-0007-0208.dcm -tag 0008 0080
UZLeuven

Seems as if dcminfo -all gets floats correct, but dcminfo -tag does not.
Is there a bug in dcminfo -tag for FL?

Thx, for any advice.

Stefan


#2

Yes, it’s fair to say that option is not working as it should… I’ll fix that ASAP.


#3

Hi Donald,

A temporary workaround in bash:

local waterfatshift=$(dcminfo "$dcm_file" -all | grep WaterFatShift | awk '{print $(NF-1)}')

I use the wfs, fieldstrength, epifactor, etc… to calculate effective echo spacing and total readout time to be used later in the topup step of dwipreproc. Some vendors don’t provide ees/trt and that can be a hassle (in a multicenter study with many different dicom formats). Any function that does this in mrtrix3 for all major vendors? :sunglasses:

Best regards,
Stefan.


#4

OK, fix for the original issue is now available on master. You can upgrade with:

git pull
./build

Let me know if that works for you.

Not yet… But if you have a formula that works across vendors, we can certainly think about implementing it! :grin: