Dwipreproc - Eddy error: global index not dwi


#1

Hi,

I’ve been trying to preprocess my data and got a few errors during the dwipreproc step. I used the following line:

dwipreproc 202dwi_den_unr.mif 202dwi_den_unr_mdc.mif -pe_dir AP -rpe_pair -se_epi 202dwi_b0_re.mif -eddy_options " --slm=linear"

After this line I got the error that my data wasn’t shelled so I added the data_is_shelled flag.
This brings me to the next error:

dwipreproc: [ERROR] Command failed: eddy_openmp --imain=eddy_in.nii --mask=eddy_mask.nii --acqp=eddy_config.txt --index=eddy_indices.txt --bvecs=bvecs --bvals=bvals --topup=field --data_is_shelled --out=dwi_post_eddy (dwipreproc:853)
dwipreproc: Output of failed command:
eddy: msg=ECScanManager::GetGlobal2DWIIndexMapping: Global index not dwi
terminate called after throwing an instance of ‘EDDY::EddyException’
what(): eddy: msg=ECScanManager::GetGlobal2DWIIndexMapping: Global index not dwi

So far I can’t seem to find a solution and I was hoping someone knows how to solve this error

Thanks!
Ida


#2

Hi Ida,

That error is coming from deep inside eddy code, and I’ve never encountered it myself, so unfortunately I can’t help beyond suggesting the FSL forum. Always a chance that somebody else on here has come across it though.

Rob


#3

Hi Rob,

Thanks for your reply!
I’ve heard someone who had the same problem and to him it was suggested to use the --ol_nstd and raise it to 5 or 6 so I’ll give that a try.
If/when I found a solution I will let it know!

Best,
Ida


#5

So the --ol_nstd option didn’t work out either.
Someone mentioned to check the DWI images more carefully and it turned out my b100 images were the problem.
After leaving them out it was solved, so for now I will continue without those images