dwipreproc output and eddy_quad

Dear MRtrixr3 developer
I have run dwipreproc with -eddyqc_all option (also tried -eddyqc_text)

dwipreproc -pe_dir AP -rpe_pair -se_epi Blips.nii.gz -fslgrad B1000.bvec B1000.bval -export_grad_fsl B1000_dc.bvec B1000_dc.bval B1000_gc.nii.gz B1000_dc.nii.gz -nthreads 4 -force -eddyqc_all B1000_eddyQC

and then I pass the output to

eddy_quad B1000_eddyQC -idx 1000_index.txt -par acqparams.txt -m B1000_brain_mask.nii.gz -b B1000.bval

I got following error:

Traceback (most recent call last):
  File "/usr/local/bin/eddy_quad", line 4, in <module>
    __import__('pkg_resources').run_script('eddy-qc==1.0.0', 'eddy_quad')
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 658, in run_script
    self.require(requires)[0].run_script(script_name, ns)
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 1445, in run_script
    exec(script_code, namespace, namespace)
  File "/usr/local/lib/python2.7/dist-packages/eddy_qc-1.0.0-py2.7.egg/EGG-INFO/scripts/eddy_quad", line 52, in <module>
    
  File "build/bdist.linux-x86_64/egg/eddy_qc/QUAD/quad.py", line 61, in main
ValueError: . does not appear to be a valid EDDY output basename

also tried on python 3, same problem

For the next tag update I have dwipreproc internally executing eddy_quad if -eddyqc_text or -eddyqc_all is specified. It’s a little difficult to get a traceback, but you can see the final resulting code here. Maybe there might be some clue there as to how to get it working. I do seem to have documented in a comment there that QUAD does not work with Python2 (at least it didn’t when I wrote the code), but the exception you’re seeing doesn’t appear to be related to Python version.

It’s more likely to have something to do with fine names. I’m pretty sure that the DWI - “B1000_dc.nii.gz” in your case - and the additional files that are written by eddy and read by the eddy_quad command - here exported to a directory “B1000_eddyQC/” - need to have the same basename; i.e. differ in file extension only.