Lamb brain tractography

tractography

#1

Dear Matrix experts,

I have multi-shell diffusion data in preterm lamb brain(bv=500 & 1000). I used Multi-shell multi-tissue constrained spherical deconvolution(msmt-csd) to acquire wmFODs and tissue map. the result looks good. But when I run global tractography it doestnt show the tracks properly. I reduced -length to 0.5 and -weight to 0.01 but still doesn’t look correct (second image). Doest anyone have a solution for this problem?


#2

Dear @tara,

Sorry for not responding earlier; I was away last week.

The fact that MT-CSD comes out OK suggests that your data and response functions are fine and tckglobal should be able to get a good result too. Given that it fails so dramatically points to the parameter settings of the Metropolis-Hastings optimizer (assuming you are calling the command correctly). Based on what I can see in your screenshots, here are a few steps to try:

  1. Reducing -length to 0.5 seems very appropriate for your data.
  2. I would keep -weight at the default 0.1 for now. (By setting it to 0.01 the no. degrees of freedom increases by a factor 10, making the optimization more complicated.)
  3. Do make sure that you run tckglobal with enough iterations. I typically recommend -niter 1e9 for adult full brain data, but you may need more depending on the voxel size and segment weight.
  4. Then try gradually increasing the particle potential -ppot in a range 0.05 – 0.5.
  5. If this doesn’t help, you may need to tune the start and end “temperature” -t0 and -t1.

If you want, send me one of your datasets and I’ll have a look.

Cheers,
Daan


#3

Dear Daan,

I added new parameters but didn’t get a good result out of it. I emailed you my dataset. Thank you for your help.

Cheers,
Tara