Mrview window gets into full black screen when viewing ODF image

mrview

#1

Dear,
I run MRtrix3 on VMware Ubuntu 16.04. The RAM of Ubuntu is 20G.
My raw data is about rat brain. I used command “dwi2fod” ,and got the fod.mif. When I use mrview to show it, the mrview window always got int full black screen.
The pictures I uploaded is the PNG of “black mrview window” and debug results.
I have no idea what should I check now.
Thanks


#2

The fact that the window shows up in gray-scale suggests that the OS (or rather, the window manager) thinks the application is dead and not responding. Looking at your setup, you’re running this using the VMware OpenGL drivers, which advertise themselves as Mesa gallium LLVM – this looks suspiciously like the Mesa open source software-only renderer, with no hardware acceleration. If this is the case, and what you’re trying to display is a very complex scene (which is the case with a full screen ODF render), then it could simply be stalling while processing the render. However, it does look like it did manage to display something, so maybe that’s not the whole story…

Can you confirm that it does render regular images ok? Assuming this is the case, can you try opening the ODF render tool manually (not via the command line), making sure the window size is as expected, zooming in until only a relatively small number of voxels are visible, then loading the ODF image manually. At that point, the amount of work needed for the frame should be minimal.

If that works, then the likely problem might be the unexpected window resize that happens when invoked via the command line, causing the render to be much larger than expected, with much of it outside the visible window (this might cause issues in and of itself, depending on how well the drivers deal with this case). One issue that might be problematic here is that some of the tools report their size to be much larger than necessary (I’m not sure why, I’ve never really got to the bottom of it), and this cause the whole window to resize to accommodate. One way around this is to set a config file entry that controls whether the tools open docked in the side of the main window (the default), or floating freely above it. The option you’re looking for is MRViewDockFloating – try setting that to 1, by adding this line to your ~/.mrtrix.conf file:

MRViewDockFloating: 1

This might avoid the funny resize, and make the whole thing behave as expected…


#3

Thank you very much.
I use the command option -fov shrink the area I show and reduce the size of displaying scale of “ODF”. It looks better now only when the fov is small.