5ttgen fsl error - mrconvert

I am following “global tractography” topic in the documentation.
I got error when performing segmentation from the very first step as follow

in the error text file :
mrconvert “/home/Tran Thu Trang/t1.mif” /home/Tran Thu Trang/5ttgen-tmp-96FJ79/input.mif
mrconvert: [ERROR] Expected exactly 2 arguments (4 supplied)
mrconvert: [ERROR] Usage: mrconvert input output
mrconvert: [ERROR] Yours: mrconvert C:/msys64/home/Tran Thu Trang/t1.mif C:/msys64/home/Tran Thu Trang/5ttgen-tmp-96FJ79/input.mif
However, I can not understand what the problem is?


I think that the problem is that your directory contains spaces in the name. You can try to rename your directory replacing the spaces.



1 Like

Yes, that’s correct: the script library is supposed to deal with the presence of spaces in file paths (which can otherwise wreak havoc such as this), but one of the library functions failed to consider the possibility that the temporary directory location may also have spaces in it.

I’m making the requisite fix to the software for the upcoming update: but for now, having a temporary directory without any spaces in it will work: You could either use a different working directory, or you could use either the -tempdir command-line option or the ScriptTmpDir config file entry to explicitly set the temporary directory location to some other location that does not contain spaces.


1 Like