5ttgen subcortical GM error

Dear Mrtrix experts,

Im trying to generate the 5tt file. I run the command
5ttgen fsl T1_in_diff_spc.nii.gz 5tt.nii.gz -mask T1_in_diff_spc.nii.gz -sgm_amyg_hipp -nocrop -force
, but the subcortical GM volume that it creates, doesn’t seem to be correct. See below (it should look like the red regions, but I get the white regions)

Any clues on what might be working wrong?

Really appreciate for your work,
Thank you!

This was solved with the premasked option

5ttgen fsl T1_in_diff_spc.nii.gz 5tt.nii.gz -premasked -nocrop


This was solved with the -premasked option

That suggests that the registration step within the FSL run_first_all script was going awry when you were providing a non-brain-extracted image to 5ttgen. I don’t think this is the first time that such a “fix” has been reported.

If this is a regular issue, then it may be preferable for the 5ttgen fsl script to provide the brain-extracted image following execution of bet to the FIRST script, rather than providing it with the input non-brain-extracted image. Obviously this would mean that any issues with brain extraction may have concomitant effects on the FIRST sub-cortical segmentations; but chances are if the brain extraction is severely wrong then one won’t care about how well FIRST performs… Maybe something to consider for future updates…