Average_response python2 Error

Dear Experts,

Has anyone had this issue while trying to use average_response ? I have tried to create a symbolic link without any luck. I downloaded python using brew install and I have the executable python2 file, however, it’s in /usr/local/bin/python2 and not /usr/bin/python2. It seems challenging, even as a super user or root to try to move this file into /usr/bin/.



Haven’t come across that one before, but it sounds like this issue. It seems the symbolic link is not needed, what you need is to make sure that whatever folder contains the actual python executable is in your path. From what you state, this should do it for your setup:

export PATH=/usr/local/bin:$PATH

And try again. If that works, you’ll want to add that line to the appropriate shell startup file, presumably ~/.bash_profile on a MacOSX system.

However, I’m surprised this folder isn’t already in your PATH, as far as I understand, that’s the default location for homebrew commands. @maxpietsch, can you figure out what might be going on?

I’ve just pushed a fix so that average response relies on: #!/usr/bin/env python

And made the code python 2 and 3 compatible.

@jbishop, feel free to update and try this in half an hour or so once the tests have passed.

Careful, you do not want to do that as it might break your system.

AFAIK does not exist on OSX by default, /usr/bin/python2.7 does on my system but I think OSX should use that anyway.

average_response works for me and which python2 points to my virtual environment location in my home directory so not sure either…

Thank you all very much for the help, especially for editing the code. I upgraded the version and the command seems to be working now. Problem solved!