Difficulty installing MRtrix 0.2.12 on macOS Sierra


I know this is an MRtrix3 community, but I was told that the old MRtrix2 mailing list is inactive now, so my best chance would be to post this here. Hope I’m not breaking any rules!

I’m trying to install MRtrix 0.2.12 on a macOS Sierra 10.12.3, but for some reason I can’t manage to compile it. I installed both Xcode and Xquartz (the X11 substitute), and I successfully installed the dependencies using both Macports and Homebrew (on 2 separate occasions), but when try to compile it using:

$ cd mrtrix-0.2.10
$ ./build

I get the following error:

-bash: cd: mrtrix-0.2.10: No such file or directory

Same error with both methods. I can’t even find a directory named “mrtrix-0.2.10”, so I completely understand the error message.

What am I missing? I’m quite new to coding, so forgive me if my question is more on the novice side of things. I feel like the solution to my problem is really simple, but I just can’t figure it out! I’d be very grateful if someone can help me out. Thanks!


It’s true that the old mailing list will eventually be closed off, when we eventually phase out support for MRtrix 0.2. But it’s still the most appropriate forum for that version, no problem on that front. On the other hand, it is true that these days, you’ll probably reach more people on this forum than the old mailing list.

I think it’s just that the instructions aren’t quite up to date with the version you downloaded. Have you tried:

$ cd mrtrix-0.2.12