DW gradient image header

Dear community:
I am having issues doing the preprocessing for structural connectome. I have done eddy with openmp version of FSL. But the issue comes when I want to do
dwibiascorrect ants sub-02_den_preproc.mif sub-02_den_preproc_unbiased.mif -bias bias.mif
I don’t have “bias.mif”. All I did was converting eddy output file into mif with mrconvert.

I have this error.
dwibiascorrect: [ERROR] No valid DW gradient scheme provided or present in image header

This will most likely be the problem. How exactly did you perform this step? If you didn’t include the bvecs/bvals at conversion time, DW gradient scheme won’t be available in the image header of the sub-02_den_preproc.mif image, which this command expects to find. You can trivially check for this by running:

mrinfo sub-02_den_preproc.mif

and check if there is a DW scheme entry in the output.

If you need to convert DWI data from NIfTI to mif, you should pretty much always make sure the corresponding bvecs/bvals are also included in there, like this:

mrconvert dwi.nii -fslgrad bvecs bvals dwi.mif

oh thank you very much. I didn’t includ th bvec bvals so that is the issue.

If I wanted to do the opposite do I need to use fslgrad option as well? that is converting “.mif” to “.nii.gz” of this file. The one that comes out of dwifslpreproc. I just need the dwi eddy current corrected in “.nii.gz”.


if you just need the .nii.gz you can do mrconvert input.mif output.nii.gz. However, I don’t recommend doing this, at some point you’ll need the bvecs and bvals as well, so the command is mrconvert input.mif output.nii.gz -export_grad_fsl bvecs bvals. I hope this helps.

Best regards,


I have the bvecs and bvals already so I don’t need this option I guess. Thanks!


Glad it help. I was just saying that because after dwifslpreproc the bvecs change.

Best regards,


ah then I need them.Thanks!!