DWI acquisition protocol on GE scanner

Dear MRtrix users,

I am working, on the DWI data taken from the GE 3T scanner and after running the complete pipeline up to tcksift, the results are not good for clinical purpose, I am attaching all the relevant information, along with the DWI protocol, we are acquiring only single B0 image (only the first image), and rest all have the b0=1000, voxel size of 1x1x2.9.


Please find the attached screenshot, of the output of tcksift algorithm, I ran, dwidenoise, mrdegibbs, dwifslpreproc, biascorrection, dwi2response, dwi2fod, mtnormalise,Processing: dwi protocol.txt…

tckgen (wholebrain_10M), tcksift.

Can you please advice what parameters should I change in my protocol to get the relevant tracks.

Thanks
Nayan

Hi Nayan,

Getting decent data on GE scanners can be tricky due to their tendency to apply zero-filling interpolation by default, with no simple way to disable it. I expect that would be the primary issue with your data: your acquired voxel size clearly isn’t actually 1×1×2.9mm, since your acquisition matrix is 122×122, which would imply a field-of-view of 122×122mm and that wouldn’t be sufficient to cover the brain. I suspect that the scanner has zero-filled your data to 256×256, which you can verify with mrinfo.

Besides, you state a slice thickness of 2mm with no slice gap, yet the voxel size comes out at 2.9mm along the z-axis, which isn’t consistent with that. I would recommend you try to get an isotropic 2×2×2mm voxel size, potentially higher than that if SNR is poor (e.g. 2.3mm isotropic).

Assuming your data have been zero-filled, my first recommendation would be to disable that. Unfortunately, the last time I looked into this, it wasn’t easy. Others on this forum may be able to help here, but I think the process was to set the image size to the same dimensions as the acquired matrix size (in your case, 122×122), but that setting was not easy to find (might even require research access).

Other than that, my recommendation would be mostly to increase the b-value to at least 2,000 s/mm² (preferably 3,000 s/mm²). And figure out why the slice thickness doesn’t match with the voxel size…

Indeed, you will need to disable interpolation. By default, GE scanners interpolate to 256x256.
So, you will need to ask a GE Apps Specialist to provide you with a research key. Once the scanner has a research key, you ‘Download CV’, type in rhimsize, and set the matrix to your matrix size which in your case in 122. After that, the reconstructed matrix will be 122 x 122 i.e. no interpolation.

Jerome

1 Like