Dwi2response: Provided mask image does not contain any voxels


I am running the following command:

dwi2response msmt_5tt DBS202_7T_dwi_preproc_unbiased.mif 5TT.mif -fslgrad bvecs bvals -mask DBS202_7T_dwi_preproc_nodif_brain_mask.nii.gz RF_WM.txt RF_GM.txt RF_CSF.txt -voxels RF_voxels.mif

however I’ve got the following error:

dwi2response tournier dwi.mif wm_ss_response.txt -mask wm_mask.mif -voxels wm_sf_mask.mif -scratch /Volumes/WD_Elements/NYC/dwi2response-tmp-LMB5KC/

dwi2response: Note that this script makes use of commands / algorithms that have relevant articles for citation. Please consult the help page (-help option) for more information.
dwi2response: Generated scratch directory: /Volumes/WD_Elements/NYC/dwi2response-tmp-LMB5KC/dwi2response-tmp-PGZEZ7/
dwi2response: Importing DWI data (/Volumes/WD_Elements/NYC/dwi2response-tmp-LMB5KC/dwi.mif) and selecting b-values...
dwi2response: Importing mask (/Volumes/WD_Elements/NYC/dwi2response-tmp-LMB5KC/wm_mask.mif)...
dwi2response: Changing to scratch directory (/Volumes/WD_Elements/NYC/dwi2response-tmp-LMB5KC/dwi2response-tmp-PGZEZ7/)

dwi2response: [ERROR] Provided mask image does not contain any voxels

FYI: I’ve tried with or without the -mask flag and I got the same error.

Any tips?


1 Like