Eddy_cuda on osx versions > 10.9

Hi MRtrix3 community,
Hi Donald, Daan, Thijs, Ben, Jelle, and colleagues,

greetings from Leuven.

For MRtrix multicore processing your -nthreads option works great!

All processing steps go fast, except the eddy (FSL) step in dwipreproc. Which roughly takes 2 hours for my dMRI data…

I’ve recently been experimenting with GPU processing using cuda on OsX.
The problem I have is that I cannot get eddy_cuda to work on OsX. I have compatible Nvidia graphics cards. I tried cuda drivers 6.5 to 8.0. The problem seems to be - however - that the latest FSL eddy_cuda is only compiled for OsX version 10.9. And I have 10.10, 10.11 and 10.12 iMacs…

Did any of you get eddy_cuda working with recent OsX and cuda versions (e.g. 10.12 OsX and 8.0 cuda)?

If so, please tell me how!

Best regards,

Stefan Sunaert

Hi Stefan,

I think your question may be better suited for the FSL mailing list, but perhaps some of the Mac users on our forum may be able to help you out? I don’t think there’s a technical reason why CUDA wouldn’t work on a >10.9 iMac with Nvidia GPU, but the FSL team will need to provide the binary of course, which may be the problem here. In any case, I could understand that FSL may not release a CUDA eddy version for more recent builds, since Apple stopped using Nvidia GPUs in their systems for a few years now.

Have you tried eddy_openmp as an alternative? That binary uses OpenMP instead of CUDA and should hence be compatible with a wider range of architectures and systems. As far as I’m aware, eddy_openmp is the only parallel version available to Mac users at the moment.

If that doesn’t help, just run eddy on avalok. It’ll still take ages, but you can process all your subjects in parallel. That’s what I used to do anyways :slight_smile: