Error linking Qt application (Centos7)


I am trying to install mrtrix3 in Centos 7.
I’ve got errors following,

I’ve attached parts of configure.log file too…

Please help me for installing mrtrix3!!

Thanks and best regards,

1 Like

Hi @SoHyun_Han,

It’s difficult to tell exactly what the problem is without the full configure.log – any chance you could copy/paste it in full in your next post, between code quotes, e.g.:

copy/paste log in here

Otherwise, it looks like the configure script is trying to use the Qt installation provided by FSL – I must admit I’ve not yet figured out why this is included in recent versions of FSL. But it clearly has created conflicts for others in the past, and I expect it will for you too. The simplest way to avoid the issue is to strip any mention of FSL from your PATH. Something like this may work for you:

export PATH=/usr/bin:/bin

I also note you’ve tried to activate a live conda environment before running ./configure – this will definitely not work, I’ve never managed to get MRtrix to build normally with the conda tools (it requires a dedicated recipe). You’ll note that the configure script has tried to strip that from the PATH, but this is not always sufficient. Please deactivate any conda environments before running configure!

All the best,