“ERROR: MRtrix3 executables not found in expected location” in Windows 10 64 bit installation

I’ve been encountering a problem during the installation after Building MRtrix step. I inserted

$ /usr/bin/python ./configure
$ /usr/bin/python ./build

which is previously suggested in other topics. (only solution worked in my computer)


didn’t work at least for me. The error for these lines that I’ve enclosed in the following:

My main question is when I continued with the step:


I’ve been receiving the following error during the installation :

ERROR: MRtrix3 executables not found in expected location.

This script needs to be run from within the MRtrix3 toplevel directory, AND
after the build script has successfully completed. In addition, the set_path
script should NOT be moved from its original location in the MRtrix3 toplevel

It would be really appreciated, if you could suggest some solutions to fix the problem.

Thank you!
Best Regards

I would try

/usr/bin/python ./set_path

Thanks for the suggestion.
I had tried that line too but the result was same

@bjeurissen: no, this is a genuine bug - hopefully fixed in this pull request. Just waiting for you to approve and merge… :wink: