Error with ./configure : Error Linking QT applicaiton

Dear Mrtrix3 Users,

I had a problem with the ./configure command while running the Mrtrix3 installation on my linux pc running Ubuntu 22.04.3 LTS (64 bit). I read through all the older posts of people facing the same problem, and tried all the recommended steps. As a last ditch effort, i also tried to understand whether there was a problem with the symbolic links in my PC, which i couldn’t really grasp . I’m including the error in this post, any help would be greatly appreciated!

CMD: g++ -Wl,–sort-common,–as-needed -pthread -L/usr/local/lib -lz qt_moc.o qt.o -o qt /home/visualdbs/fsl/lib/ /home/visualdbs/fsl/lib/ /home/visualdbs/fsl/lib/ /home/visualdbs/fsl/lib/ /home/visualdbs/fsl/lib/ /home/visualdbs/fsl/lib/ -L$(CONDA_BUILD_SYSROOT)/usr/lib64 -lGL -lpthread
/home/visualdbs/fsl/bin/…/lib/gcc/x86_64-conda-linux-gnu/12.3.0/…/…/…/…/x86_64-conda-linux-gnu/bin/ld: cannot find -lGL: No such file or directory
collect2: error: ld returned 1 exit status

ERROR: error linking Qt application!

See the file ‘configure.log’ for details. If this doesn’t help and you need
further assistance, please post on the MRtrix3 community forum
(, and make sure to include the full contents of
the ‘configure.log’ file.


Hi @Abhi,

This sounds suspiciously similar to this previous post… Hopefully the instructions in that thread will help.

All the best,