Fail to make eddy_options work when calling dwifslpreproc from Windows via WSL

Hi all, I installed MRtrix in WSL on my Windows laptop. I managed to run the MRtrix functions in MATLAB (installed in the Windows system, not WSL) via the ‘system’ function, and it works pretty well in many cases. However, when running ‘dwifslpreproc’ with specific eddy_options, I met some problems. Here are some examples:

dwifslpreproc dti_den.mif dti_den_preproc.mif -rpe_none -pe_dir ap

Everything works fine without ‘-eddy_options’

dwifslpreproc dti_den.mif dti_den_preproc.mif -rpe_none -pe_dir ap -eddy_options " --slm=linear"

Error: argument -eddy_options: expected one argument

dwifslpreproc dti_den.mif dti_den_preproc.mif -rpe_none -pe_dir ap -eddy_options=" --slm=linear"

I replaced the space between ‘-eddy_options’ and " --slm=linear" with an equal sign. The code can run in this case, but the eddy function didn’t load the eddy_options (–slm=linear). And I got a [WARNING] message like this:
[WARNING] sampling of b=500 shell is strongly asymmetric; distortion correction may benefit from use of: -eddy_options " … --slm=linear … "
This looks like the ‘eddy_options’ was not correctly loaded. I confirmed this when FSL executed the ‘eddy_cuda10.2’ function:
Command: eddy_cuda10.2 --imain=eddy_in.nii --mask=eddy_mask.nii --acqp=eddy_config.txt --index=eddy_indices.txt --bvecs=bvecs --bvals=bvals --out=dwi_post_eddy --verbose
There is no ‘–slm=linear’ in this command. This issue only happens when I run MRtrix in MATLAB. There is no issue when running it in the WSL.

I hope that I make myself clear. I appreciate any help you can provide.


It is solved. The problem is due to the double quote sign ("). Changing it to " works.