Libqt4-opengl-dev Missing ob Ubuntu 20.04

Hi there,

can somebody explain the problem or did I miss something? I didnt find any hints in the topics just an old issue at the MRTrix GIT site.
All of my Ubuntus just throw a openGL error that something is missing and if I want to reinstall the dependencies it says that 20.04 doesnt have libqt4-opengl-dev in the packages any more.
Whats the best way to work with it? Should I somehow install the Qt4 or can I switch to Qt5. In the beginning it worked with Ubuntu 20.04 they must have switches something. Didnt install or uninstall anything. or is it completly different?

sudo add-apt-repository ppa:rock-core/qt4
sudo apt-get update
sudo apt-get install libqtcore4
sudo apt-get install libqt4-opengl-dev
//It worked, but for a reinstall The moc was missing

Is this the right way or is there a better approach or even a better package or something?
That doesnt feel right or clean.



Qt4 has been deprecated for a long time now… Try using Qt5 instead. You’ll find the command to install all the relevant packages for Ubuntu 20.04 on our docs:

sudo apt-get install git g++ python libeigen3-dev zlib1g-dev libqt5opengl5-dev libqt5svg5-dev libgl1-mesa-dev libfftw3-dev libtiff5-dev libpng-dev

I think that should do the trick…

Hi and thanks for the answer.
I think google gave me allways the MRTix3 RC3 site.
That explains a lot.

Sorry, about that question.


1 Like