MRtrix3 installation on Windows 10

Hi everyone,

I followed the Windows installation instructions and was able to successfully configure and build MRtrix3. I then followed the setup step and the scripts were as followed:

File "/home/Lenovo/.bashrc" succesfully updated
(Close terminal and open a new one for change to take effect)

But when I reopened a terminal and typed mrview, nothing emerged automatically. It just prompted me to a new command.

I have checked that my graphics controller is Intel® HD Graphics 5300 and it is compatible with the OpenGL 3.3 (see reference).

So, I don’t know what’s going on. Could you please help me figure it out?

Thank you very much!

What do you mean exactly by “it prompted me to a new command”? Was there an error message (maybe “command not found”?).

Can you execute other non-graphical commands, e.g. mrinfo?

What does echo $PATH report?

What does which mrview report?

Finally, are you sure you’re using the correct terminal (the MinGW 64-bit shell)?

Hi Donald, thanks for your reply.

First of all, I am sure that I used the MinGW 64-bit shell. So, when I typed mrview , there is no error message and it shows like this:

I tried the mrinfo command and it seems to work well (i.e., it shows information about synopsis, usage, description, options).

The echo $PATH reports: /home/Lenovo/mrtrix3/bin:/mingw64/bin:/usr/local/bin:/usr/bin:/bin:/c/Windows/System32:/c/Windows:/c/Windows/System32/Wbem:/c/Windows/System32/WindowsPowerShell/v1.0/:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl

The which mrview reports:

Also, when I tried to directly run the mrview.exe, it said it can’t find libwinpthread-1.dll, libstdc++ -6.dll, libgcc_s_seh-1.dll.

@jdtournier Could you please tell me what’s going on?
Thank you very much!!

OK, my best guess is mrview is crashing out very quickly, and because Windows handles GUI applications differently from command-line applications, we don’t even get an indication of the crash.

Can you check whether shview runs? If not, then my best guess is your OpenGL drivers either don’t support OpenGL 3.3, need updating, or are somehow incompatible. But it’s very hard to debug this remotely, particularly on Windows, unfortunately.

One thing you can try is to invoke mrview -debug. That should at least get as far as probing your OpenGL drivers, and reporting what it finds. If it produces any output in the terminal, copy/paste it here and we’ll see where the problem might be.

That’s OK, these applications need to be started from the MSYS2 terminal - it sets up the right environment for the application to run. There are ways around this, but it would need a bit of tweaking to work like that.

Hi Donald, thanks for your reply.

Unfortunately, neither shview nor mrview -debug produced any output in the terminal. Does it mean that I need to reinstall the OpenGL drivers?

unfortunately, without any debugging output, it’s really hard to know what’s going on. But given that both GUI applications are failing, the most likely culprit is the OpenGL driver. So yes, I think reinstalling or upgrading your graphics card driver might fix this. If that doesn’t work, I don’t know what else I could suggest…