MRtrix3 on anaconda

Hi Donald. I have an issue trying to install MRtrix3. To tried install it on Linux. I was able to source anaconda correctly, but when I try to install MRTrix, something seems to be going wrong in the last steps of the installation:

(base) [snf18@rgs16 ~]$ conda install -c mrtrix3 mrtrix3
Collecting package metadata (current_repodata.json): done
Solving environment: \ 
The environment is inconsistent, please check the package plan carefully

and then: 

(base) [snf18@rgs16 ~]$ mrtrix
bash: mrtrix: command not found
(base) [snf18@rgs16 ~]$ source activate mrtrix3
Could not find conda environment: mrtrix3
You can list all discoverable environments with `conda info --envs`.

(base) [snf18@rgs16 ~]$ conda info --envs
# conda environments:
base                  *  /apps/source/anaconda/anaconda-2020.05-again

(base) [snf18@rgs16 ~]$ module avail anaconda

---------------------------- /apps/modulefiles/base ----------------------------
anaconda/2.4.1          anaconda/4.2.0          anaconda/4.8.2
anaconda/2-5.0.1        anaconda/4.3.0          anaconda/bak
anaconda/2-5.0.1-extras anaconda/4.3.0-p2       anaconda/default
anaconda/3-5.0.1        anaconda/4.3.1          anaconda2/4.2.0
anaconda/3-5.0.1-extras anaconda/4.4.0          anaconda2/default
anaconda/4.10.3         anaconda/4.4.0-p3       anaconda4/4.3.0

Can you help me with this issue?

Thanks in advance for your attention.

Looks like there is a conflict with your current environment. Have you tried installing to clean environment?

conda create --name mrtrix python=3.8
conda activate mrtrix
conda install -c mrtrix3 mrtrix3