MRview crashing on big sur

Hi MRTrix,

With the joy of a new laptop comes the annoyance of a new OSx …

I installed mrtrix on big sur OSx useing the install script,

while everything worked (including mrview after granting it full disk and folder access)
After restarting mrview crashes everytime, as does freeview from Freesurfer.
fsleyes is not doing this issue.
I figure it still has to do with some of the Catalina/Big sur privacy updates but can’t figure out why and how.

I get following error:

mrview -debug
qt.qpa.plugin: Could not load the Qt platform plugin "cocoa" in "/Applications/topas/Frameworks" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: cocoa.

/usr/local/bin/mrview: line 8:  3024 Abort trap: 6           " ${f}"/ "$@"

It is telling me the issue is with Qt, but I did reinstall Qt through brew, and still it fails.

Anybody any idea?

Thanks in advance,


So I found the issue, it was another program (topas) that was overwriting the QT path.

When I removed that overwrite mrview worked like a charm.

1 Like

:no_mouth: Really glad you figured this out… I don’t think I would ever have guessed this could be the problem!

Thanks for reporting back, I’m sure it’ll come in handy if & when others encounter similar issues. :+1: