MRView in mac -- not working

Really sorry for the long post. I am a new MRTrix user from UMass trying to visualize DTI data from patients in a mindfulness study. I have a brand new IMac Pro machine which should support up to OpenGL 4.1. I installed MRTrix through homebrew per , including QT and other dependencies, and my MRView seems to open a blank window with no tools or images (I tried structural, functional, and DTI .nii and .mif files).

Several troubleshooting steps I’ve taken was to create an mrtrix.conf file in my /etc/ folder with:

NeedOpenGLCoreProfile: 0

Which then instead of launching MRView as a blank screen will then crash with errors:

mrview: [WARNING] unable to determine OpenGL version - operation may be unstable if actual version is less than 3.3
mrview: [ERROR] GLSL log [vertex shader]: ERROR: 0:1: ‘’ : version ‘330’ is not supported
ERROR: 0:1: ‘’ : syntax error: #version
ERROR: 0:2: ‘layout’ : syntax error: syntax error

mrview: [ERROR] error compiling OpenGL vertex shader ID 1

mrview: [SYSTEM FATAL CODE: SIGSEGV (11)] Segmentation fault: Invalid memory access

My QT version is 5.12.0 . Also, per: openGL problem with mrview on Mac OSX I ran (pasted into my command line directly):
export PATH=brew --prefix/opt/qt5/bin:$PATH
Which didn’t seem to change anything.

I’m really frustrated and at my wit’s end, so any advice is appreciated. Thank you!

This seems to be the same issue as detailed in Help installing in macos mojave 10.14.2 but I don’t really understand how the user went about fixing the issue and getting the results in the last post.

I’m having the same issue with mrview on Mojave. Haven’t get got to the bottom of the matter.

On my 2013 macbook air, mrview works fine with mojave. I noticed I am using the Qt provided libraries ( and not those provided from macports or homebrew. You could try those instead.

Reinstalling QT did not work. I ran

brew uninstall --ignore-dependencies qt

then downloaded the dmg, installed QT 5.12.0 and all the “extras” to Users/username/QT, and then ran

export PATH=/Users/username/Qt/5.12.0/clang_64/bin:$PATH
brew reinstall mrtrix3

Which let the reinstall succeed but then running mrview still left me with a blank screen as before. So, no luck on the manual QT install approach.

Hi @Serge,

I can reproduce the issue on my macbook pro with macOS Mojave 10.14.3. As the issue happened right after I upgraded the Qt version recently, I suspect that the problem might be related to some changes in Qt:

I have tested MRtrix3 installation with Qt version 5.11.3, 5.12.0, and 5.12.1 (via a manual link to Qt libraries). The issue appeared only on 5.12.0. On my laptop, the issue came up when I opened multiple mrview windows (i.e. the first window was fine, but all the later ones went wrong). Also, if I had some other software packages running in the first place (e.g. Matlab), then the issue appeared on my first mrview window.

So, I would suggest trying with Qt 5.12.1; it works all fine for me.

@chunhungyeh This worked!! Thank you so much!

For future replication/to summarize, I downloaded the QT installer, uninstalled the current qt version with

brew uninstall --ignore-dependencies qt

if it was installed by homebrew, or by running the “maintenance tool” in the qt install directory if it was manually installed. I then used the downloaded QT installer to set up specifically QT version 5.12.1 to the /Users/username directory, and then ran

export PATH=/Users/username/Qt/5.12.1/clang_64/bin:$PATH
brew reinstall mrtrix3

Which allowed me to use MRView as needed/with tools, and I was able to open my .mif images.

Thanks for the steps. It worked for me as well.