Mrview issue - viewer opens and seems to be running normally but with visual glitches

Think I must have done something wrong in installing MRtrix as I’m having some issues with mrview (always opens glitchy like in the image below). I followed the instructions for installing MRtrix3 through MSYS2 for windows, and I’ve tried setting NeedOpenGLCoreProfile to 0 in the config file per advice from here Display issues — MRtrix 3.0 documentation but it doesn’t seem to have made a difference.

thank you

1 Like

Welcome Sophie!

… Have you tried turning it off and on again? :rofl:

I don’t have any recollection of seeing anything like that.

Are you able to get to “OpenGL information” via the “i” icon at the top right? That will provide information about your video card + drivers, though if it appears similarly corrupted it might not be of much use.

If not, can you let us know what video card you are using, + driver version if possible. Running mrview with the -debug flag will provide this, but it would be preferable to also confirm manually that that information is correct.


Hahaha Hi Rob!

Funnily enough the menus open from each icon completely fine…
This is what it says when NeedOpenGLCoreProfile is set to 0:

Can confirm it’s Intel(R) UHD Graphics with driver version

Do you think I should try downloading a more recent driver version? Device manager says “The best drivers for your device are already installed” but I can see this is an older one .

Thank you!

  • Sophie

(This is when NeedOpenGLCoreProfile: is not specified in the config):

Hi Sophie,

I had similar looking issues on my Windows 10 HP laptop, with an Intel HD Graphics 620 GPU. In my case, changing the driver fixed the problem. I can’t remember the details exactly, but I have a feeling that using the latest version of the drivers direct from Intel created problems, which were fixed by using the previous version of the Intel drivers. I can’t remember why I decided not to use the HP-supplied drivers, but it may have been because of these issues – sorry, I can’t quite recall…

All this to say I reckon this is going to be a driver-related issue, and you may find trying different (recent) versions of the drivers may sort out the issue for you…

All the best,

Hi Donald,
Thank you for the advice! I changed the driver to a version that was more recent than the one I had but still kinda old and that has fixed the issue :grinning: (it’s version if by fluke someone has the same issue as me and comes across this).

Thanks Rob and Donald :+1: