Multiple problems trying to download MRITRIX3


I am a neuroradiologist (from Australasia but based in North America) trying to download MRITRIX3 without success on several systems.

I confess I’m not the most technical person, but would appreciate some help:

I loaded all the dependencies (or so I thought, based on instructions on the MRITRIX website) but keep running into the following errors:

In my most recent attempt on my Mac OS, I installed the dependencies using macports.

When I tried to compile mrtrix I entered: cd mrtrix-0.2.10 and got:
No such file or directory.

Then I tried:
tar xjf mrtrix-0.2.X.tar.bz2

and got:
Failed to open ‘mrtrix-0.2.X.tar.bz2’

Please would someone advise what to do?
I have tried to download this multiple times using Mac and Windows and keep running into problems. Please help.


Hi Gerard,
Looks like you are downloading and trying to install the old MRtrix v0.2 tar file. To install MRtrix3, use the instructions found here.

Thank you Dave,

I tried that and now I’m getting:
2016-10-16 22:04:20 -0400


no matlab binary found
Warning: It appears you have MacPorts or Fink installed.
Software installed with other package managers causes known problems for
Homebrew. If a formula fails to build, uninstall MacPorts/Fink and try again.

If reporting this issue please do so at (not Homebrew/brew):

So I updated all my software and tried again.

When I tried to build mrtrix I got the following error message:
MRtrix3 was unable to compile a test program involving Eigen3.

Set the EIGEN_CFLAGS environment variable to inform ‘configure’ of
the flags it must provide to the compiler in order to compile
programs that use Eigen3 functionality; this may include the path to
the Eigen3 include files, as well as any required flags.
For example:
$ export EIGEN_CFLAGS="-isystem /usr/include/eigen3"
(amend with the actual path to the Eigen3 include files on your system)

Hello Gerard,

Mixing package manager is rarely a good idea. If you do not need macports and fink, I would suggest to remove them before running brew doctor and fix all issues that it reports. Then run brew update && brew upgrade and install mrtrix3 on OS X via homebrew with brew install mrtrix3 -v -without-matlab. If this still fails, please report the output of the last command.


Hi Max,

thank you for the help. I think I’m a little bit closer.

I tried to configure mrtrix and got the following error message:
Detecting OS: darwin
OS X deployment target: 10.11
Checking for C++11 compliant compiler [clang++]: 4.2.1 - tested ok
Detecting pointer size: 64 bit
Detecting byte order: little-endian
Checking for variable-length array support: yes
Checking for non-POD variable-length array support: no
Checking for zlib compression library: 1.2.5
Checking for Eigen 3 library: 3.2.10
Checking shared library generation: yes
Checking for Qt moc:
ERROR: Qt moc not found!

MRtrix3 was unable to locate the Qt meta-object compiler ‘moc’.

Make sure your PATH environment variable includes the location of the correct
version of this command, for example:
$ export PATH=/opt/qt5/bin:$PATH
(amend with the actual path to the Qt executables on your system)


From your error message I take that you did not use homebrew but tried to compile mrtrix3 yourself. You can install the dependencies with homebrew as described here:

Install Qt5: brew install qt5
Install pkg-config: brew install pkg-config
Add Qt’s binaries to your path: export PATH=`brew --prefix`/opt/qt5/bin:$PATH

and then repeat ./configure && ./build (in the same shell).


Thank you Max and Dave.

It is working now! Thanks a Million.