New installation "unresolvable dependencies"


I’m completely new here and am trying to access MRtrix3 (3.0.3) and am following the instructions on this page: Windows pre-compiled MSYS2 install (

When I get to this part and enter this long command in MINGW64 (the blue one) I get this error:
“The following package cannot be upgraded due to unresolvable dependencies”

Any suggestions on how to proceed?

I have downloaded the package from Github too but am not sure what Pacman commands to use to install it.

The same instruction page also says for 3.0.1+ that Pacman isn’t used. I’m not sure if I’m understanding this correctly. Does this change the way it needs to be installed?



I’m not sure what’s going on here, it’s been a while since I’ve used the MSYS2 version. But I’ll see if I can answer your questions:

Yes, the previous instructions suggested to add a repository to the package manager, but this proved to be more complicated to maintain than simply providing the packages as-is. So if you had added that repo to your pacman configuration, you would now find a warning about it not finding that repo if you tried to update your installation. If that’s not the case for you, you can simply ignore it.

That would be simply:

pacman -U mingw-w64-x86_64-mrtrix3-3.0.3-1-x86_64.pkg.tar.xz

I’m not sure why that’s happening, I’ll look into it now.


By the way, if you’re on Windows 11, you’re probably better off using WSL2, and installing MRtrix on that using the instructions for Linux. The modern version of WSL2 on Windows 11 supports native graphics, and provides noticeably better performance than MSYS2. I’ll need to update the installation instructions in due course…

OK, I’ve had a look, and I can’t reproduce the issue… Can you try the following at the MinGW64 terminal, and then try again to install the package:

Full upgrade of all MSYS2 packages:

pacman -Syu

Manual install of Qt5 dependency:

pacman -S mingw-w64-x86_64-qt5

If things still don’t work after that, that would be weird…

Hi jdtournier,

I followed the instructions on a different page “Building from source”
pacman -S git python pkg-config mingw-w64-x86_64-gcc mingw-w64-x86_64-eigen3 mingw-w64-x86_64-qt5 mingw-w64-x86_64-fftw mingw-w64-x86_64-libtiff mingw-w64-x86_64-libpng

It appears that this command worked and these must have been the unresolvable dependencies that were not properly working in the previous instruction list.

Despite all of this, at some point in the BATMAN instruction list, the installation went catastrophically wrong and destroyed my computer (I made another post about it, it’s currently pending approval). It corrupted my OS and I lost a bunch of files.

Hi @Elijah_S,

Sorry to hear your computer got fried – but I can assure you there’s no way this could be related to our specific instructions, it’s much more likely to be related to the FSL install instructions, and more specifically the installation of WSL2, which requires a much deeper integration into the system than MSYS2 does (WSL2 is essentially a full virtual machine).

Nevertheless, there was indeed an issue with the dependencies on MSYS2, which will be due to changes in the MSYS2 project in terms of how they’ve decided to package up Qt5. I’ve looked into it and updated the package file and the corresponding instructions. This seems to work fine on my system following a completely fresh install. Let me know if you still encounter issues with it.

All the best,