No eddy correction was applied after dwifslpreproc and no error reported

Dear MRtrix community,

I was trying to preprocess my dwi data. The data is obtained with a PA-direction for primary data file (all b values) and a AP-direction b0 files. I extracted the first b0 from the PA primary data file and combined it with the averaged AP b0 images. Below is the command I ran: (I ran it on singularity)

singularity exec ${mx} dwifslpreproc DWI_DN_UR.mif DWI_DN_UR_UD.mif -nocleanup -pe_dir pa -rpe_pair -se_epi MEAN_PA-AP-PAIR.mif -eddy_options " --slm=linear  --data_is_shelled"

However, the output images did not show any difference and the distortion correction seems to not be applied. (see below, it still seem to have some distortion)

I did the eddy correction separately in FSL for checking, and below is the screenshot using topup+eddy. It seems that the distortion has been corrected.

Therefore I think there might be some settings in fsldwipreproc that I need to change to make the correction working. The version Iā€™m using is 3.0.4. Appreciate any help!


1 Like

Hi, I wanted to update my post. I got it working by adding two flags in the command (the readout time and align_seepi):

singularity exec ${mx} dwifslpreproc ${PP_DIR}/DWI_DN_UR.mif ${PP_DIR}/D
WI_DN_UR_UD.mif -nocleanup -force -pe_dir pa -rpe_pair -se_epi ${PP_DIR}/MEAN_PA
-AP-PAIR.mif -readout_time 0.02943 -align_seepi -eddy_options " --slm=linear  --