Problem using 'labelsgmfix ' command

Hello, I have problem using 'labelsgmfix ’ command
I searched similar topics and found some people suffering same problem but I couldn’t fix.
I am following the tutorial on HCP data and when I use labelsgmfix command, I got error message,

I checked my FSL version and it’s 5.0.10…
I tried with .mgz file, also without -premasked option with un-BET image and getting the same error message.
I wonder that this problem is because of parallel computing.
If so, can I separate the ‘labelsgmfix’ command?

I look forward to get some help


I solved with command 'unset SGE_ROOT’

Hi Minchul,

Yes, disabling SGE is the easiest way to get around this issue. It’s slightly confusing because the script is trying to present you with an error message, but then encounters an issue in the creation of that error message. Use of the 5ttgen fsl and labelsgmfix scripts, which wrap FSL’s FIRST method, has been an ongoing saga. I’m hoping that coming changes will make these scripts more robust, and additionally permit the use of SGE.