Problem with mrregister


Firstly I am enjoying using this software, thank you to the team for creating it. It is very intuitive and the documentation is very well set out and easy to follow.

AS part of a study I am analysing I was to register a T1 volume to DWI scan prior to further analysis. I have tried doing this using the mrregister command but have encountered an error which I have not been able to overcome.

The error reads as such:
[ERROR] input images do not have the same number of dimensions

The information of both scans is shown below in the images.

Firstly, am I doing something really silly and secondly is what I am trying to do possible?

The mr viewer doesn’t seem to have any problem overlaying the images if this helps.

Thanks for any help anyone can give.


Hi Jan,

The T1 image is likely a 3D image the DWI image is a 4D image. You’d need to reduce the DWI image to a 3D image for instance by averaging across volumes (mrmath b0_in.mif mean -axis 3 b0_out.mif).

However, I doubt that registration will work with mrregister. Have a look in the forum for alternatives. For instance: Registration of structural and diffusion weighted data

Hi Max,

This worked perfectly, thanks so much for your help.