Problems installing mrtrix with gui on unbuntu


I’m trying to install mrview, so I need to install mrtrix with the gui. I have tried on both ubuntu 16.04 and 18,04, but i run into this problem:

$ ./configure

MRtrix build type requested: release version

Detecting OS: linux
Machine architecture set by ARCH environment variable to: native
Looking for compiler [clang++]: not found
Looking for compiler [g++]: g++ (Ubuntu 5.4.0-6ubuntu1~16.04.11) 5.4.0 20160609
Checking for C++11 compliance: ok
Checking shared library generation: ok
Detecting pointer size: 64 bit
Detecting byte order: little-endian
Checking for variable-length array support: ok
Checking for non-POD variable-length array support: ok
Checking for ::max_align_t: 16 bytes
Checking for std::max_align_t: 16 bytes
Checking for Eigen3 library: 3.2.92
Checking for zlib compression library: 1.2.8
Checking for "JSON for Modern C++" requirements: ok
Checking for TIFF library: LIBTIFF, Version 4.0.6
Checking for FFTW library: fftw-3.3.4-sse2-avx
Checking for Qt moc: moc (version 4.8.7)
Checking for Qt qmake:
ERROR:  Qt qmake not found!

  MRtrix3 was unable to locate the Qt command 'qmake'.

  Make sure your PATH environment variable includes the location of the correct
  version of this command, for example:
    $ export PATH=/opt/qt5/bin:$PATH
  (amend with the actual path to the Qt executables on your system)

I have qmake installed on my machine.

$ which qmake

and have already added it to my path before configuring but i still run into the same error.

Thanks for your help!

Hi Thomas,

That is a different qmake. I am guessing that is from Sun Grid Engine (SGE) and also includes tools like qsub, qinfo, qhost, etc.

I am not on an Ubuntu system right now but I have had to use QMAKE=qmake-qt5 before ./configure on Fedora systems as they have changed the name so you can have qt4 and qt5 installed together. You have moc so that suggests you have qt packages installed but you might still need something like qt-qmake.



Can you post the contents of your configure.log file? That usually gives us a better idea of where things might be going wrong.

Hi, thanks so much for your response!!! I didn’t realize I had to use another qmake, i changed my path to /usr/bin/qmake and then it worked perfectly!