Processed DWI in other programs


I have pre processed DWI in TORTOISE in nifti format

can I upload it to MRTRIX for response function estimation and CSD?



There shouldn’t be any issues. Have you tried…?


thank you for your prompt response,

since I am used to process data with TORTOISE I would like to upload mi .nii process file (I also have the mask and bvecs and bvals files) to MRTRIX for CSD

I have in one folder the DWI.nii, bvecs, bvals and mask

The data is Philips 32 dir, one b0 and the rest 1000

I get this error:

Command:  mrconvert /Users/avnermeoded/Desktop/test-hardi/mau/fsl/dwi.nii - -stride 0,0,0,1 -grad /Users/avnermeoded/Desktop/test-hardi/mau/fsl/bvecs | dwiextract - /Users/avnermeoded/Desktop/test-hardi/mau/fsl/dwi2response-tmp-Y2SIGM/dwi.mif -singleshell -no_bzero
dwi2response: [ERROR] Command failed: mrconvert /Users/avnermeoded/Desktop/test-hardi/mau/fsl/dwi.nii - -stride 0,0,0,1 -grad /Users/avnermeoded/Desktop/test-hardi/mau/fsl/bvecs | dwiextract - /Users/avnermeoded/Desktop/test-hardi/mau/fsl/dwi2response-tmp-Y2SIGM/dwi.mif -singleshell -no_bzero (dwi2response:86)
dwi2response: Output of failed command:
dwiextract: [ERROR] number of studies in base image does not match that in diffusion gradient table
dwiextract: [ERROR] unable to get valid diffusion gradient table for image "/tmp/mrtrix-tmp-vFTLzX.mif"
dwi2response: Changing back to original directory (/Users/avnermeoded/Desktop/test-hardi/mau/fsl)
dwi2response: Script failed while executing the command: mrconvert /Users/avnermeoded/Desktop/test-hardi/mau/fsl/dwi.nii - -stride 0,0,0,1 -grad /Users/avnermeoded/Desktop/test-hardi/mau/fsl/bvecs | dwiextract - /Users/avnermeoded/Desktop/test-hardi/mau/fsl/dwi2response-tmp-Y2SIGM/dwi.mif -singleshell -no_bzero
dwi2response: For debugging, inspect contents of temporary directory: /Users/avnermeoded/Desktop/test-hardi/mau/fsl/dwi2response-tmp-Y2SIGM/

any idea what might be the problem?

thank you


Hi Avner,

By your command line looks like you have the bvecs and bvals obtained from FSL, so the -grad obtion won’t work, the correct option is -fslgrad. If this is the issue, this should work and the images should be converted.



do you know what are the files required for -fslgrad? only bvecs?



-fslgrad bvecs bvals

got it.

that worked perfectly

Thank you