Tckedit doesn't work properly

Dear MRtrix Experts,

I have used tckedit to segment fornix tract and the fornix tract look good, but I also have fibers from other regions (please see the image). Can you please help me to remove those fibers?


Hi @cmid,

The streamlines that are “from other regions” are all guaranteed to be satisfying whatever conditions you have put in place for generating / selecting streamlines corresponding to the fornix. The issue is that those streamlines both pass through the fornix and traverse to other regions of the brain. If you wish to prevent such from appearing, you can either use the -exclude option (in either tckgen or tckedit), such that any streamline reaching one of the unwanted areas is immediately discarded, or you can use the -maskoption (again in eithertckgenortckedit`) to constrain the region within which streamlines are permitted to propagate, with streamlines terminating as soon as they attempt to enter the mask.