Tcksample: how to remove command history from .csv file output

Dear MRtrix community,

I recently updated the MRtrix software on our server (it turned out we were on a 2019 version), and I am now experiencing an issue/change in the output of .csv files using tcksample.

I used to get a .csv file which just contained the number of mean FA values per streamline, but now the first row contains the command history, and the second row the output values. I use R to gather all the values from the .csv files into one large data frame to perform statistics, but now I have difficulties isolating the numerical values to do calculations with when I read the .csv file in R. I could not figure out from the tcksample documentation if there is a way to not include the command history in the .csv file.

So my question is: how do I output .csv files from tcksample without the command history in the first row?

Kind regards,

This is not possible. However, it should be trivial to ignore these lines during the csv import in R as they always start with a #-character. E.g. the option comment.char = “#” of read.csv should take care of exactly your issue.