Tensor visualisation


I am trying to visualise tensors after running

dwi2tensor dwi.mif dt.mif

but upon loading in mrview this is what I am seeing:

mrview dt.mif

mrview dt.mif -odf.load_tensor dt.mif

I have tried dwi2tensor on a MacBook, an iMac and a cluster running ubuntu (all with mrtrix/3.0_rc3) and images from three different datasets at b1000/30dir and b3000/60dir (and the images were converted from DICOM with mrconvert).

However, the following command works fine:

dwi2tensor dwi_biascorr.mif - | tensor2metric - -fa - | mrcalc - mask.mif -mult fa.mif

I also tried running dwi2tensor dwi.mif dt.mif with mrtrix/3.0_RC1, but the command simply gets stuck at dwi2tensor: [100%] computing tensors (it never finishes).

Any help is much appreciated.


This sounds to me like the same issue as in this recent thread. The problem is probably simply that you’re getting totally wild ADC values (i.e. values for the tensor elements) in non-brain regions. You try simply masking the data at the dwi2tensor stage, i.e.:

dwi2tensor dwi.mif -mask mask.mif dt.mif

That ought to get rid of most of the problem – but probably not all of it, there’s likely to be a few remaining non-brain regions included in the mask that still cause trouble…

That was exactly the issue. Many thanks.